Elevated failure rate for transactions

Incident Report for Softpay

Postmortem

An update introduced a bug in the threat rule evaluation that incorrectly flagged devices running older app versions, moving some terminals to obesevation/blacklist.

The update has been rolled back and transactions are processing normally.

Posted Apr 21, 2026 - 10:24 CEST

Resolved

Routine maintenance caused a brief increase in failed transactions, isolated to a small subset of terminals. The issue has been resolved and transactions are processing normally.
Posted Apr 20, 2026 - 06:30 CEST