Payments slow or failing

Incident Report for Softpay

Resolved

Issue has been identified and resolved.
Posted Apr 01, 2025 - 10:04 CEST

Investigating

Payments are currently slow / failing. We are investigating. Next update 10:15.
Posted Apr 01, 2025 - 09:57 CEST
This incident affected: Softpay Production Environment.