Elevated failure rate for Mastercard transactions

Incident Report for Softpay

Resolved

Mastercard had global issues. Transactions are working again.
Posted Aug 15, 2026 - 08:04 CEST

Investigating

We are currently seeing elevated errors for a some Mastercard transactions.
All Softpay services are operating normally. We are investigating.
Posted Aug 15, 2026 - 07:56 CEST
This incident affected: Softpay Production Environment.