Transaction processing errors

Incident Report for Softpay

Resolved

The problem has been identified and fix. Transaction processing is back to normal.
Posted Mar 17, 2026 - 11:47 CET

Investigating

We are currently investigating an issue with transaction processing which may result in failures for some customers.
Posted Mar 17, 2026 - 11:42 CET
This incident affected: Softpay Production Environment.