Cloud and Login Services Issues

Incident Report for Softpay

Resolved

Service has been restored.
Posted Mar 25, 2025 - 09:49 CET

Update

We are continuing to investigate this issue.
Posted Mar 25, 2025 - 09:43 CET

Investigating

We are currently experiencing issues with Cloud and Login services. We are investigating.
Posted Mar 25, 2025 - 09:43 CET
This incident affected: Softpay Production Environment.