Sporadic issues reading MasterCard
Incident Report for Softpay
Resolved
Softpay App version 1.9.1 is available in Google Play Store and has been confirmed to address the issues we've seen with MasterCard and particularly MasterCard Wallet. Please update the app as soon as possible.
Posted Jun 29, 2023 - 11:07 CEST
Monitoring
Softpay App version 1.9.1 has now been released and is available in Google Play Store. The release addresses issues with MasterCard and particularly MasterCard Wallet. Please update the app as soon as possible. We are monitoring the results, but in case you continue to see issues with MasterCard after upgrading, please contact our support on support@softpay.io. Thank you.
Posted Jun 28, 2023 - 08:03 CEST
Identified
Softpay App version 1.9.1 has been pushed to Google Play Store and is currently in review. The release addresses issues with MasterCard and particularly MasterCard Wallet. We will follow up here as soon as the update is publicly available in Play Store.
Posted Jun 27, 2023 - 15:15 CEST
Update
We are continuing to investigate an issue where a few MasterCard payments, particularly using wallets, result in "Try another card". A workaround is to use the physical card or using an alternate card scheme.
Posted Jun 23, 2023 - 15:53 CEST
Update
We are continuing to investigate an issue where a minor fraction of MasterCard payments are rejected with "Try another card" immediately upon presenting the card. Retrying the payment with the same card is then likely to be accepted on the same device or when trying on another device.
So far our learnings indicate that the message is misleading and instead caused by the card not having time to be read.
Posted Jun 23, 2023 - 07:34 CEST
Investigating
We are currently investigating an issue where a minor fraction of MasterCard payments are rejected with "Try another card" immediately upon presenting the card. Retrying the payment with the same card is then likely to be accepted on the same device or when trying on another device.
Posted Jun 22, 2023 - 17:25 CEST
This incident affected: Softpay App and Services.